Herzlich Willkommen!

1-abc.net File Replacer
Tauschen Sie beliebig viele Dateien mit nur einem Klick aus!

Der Windows Explorer bietet dem Anwender zahlreiche Möglichkeiten um Dateien auszuschneiden, zu kopieren oder einzufügen. Dennoch, in dem Moment, wo Sie mehrere gleiche oder ähnliche Dateien überschreiben möchten, die in verschiedenen Ordnern oder auf unterschiedlichen Laufwerken liegen, müssen Sie diese Verzeichnisse zunächst selbst suchen, um dort dann eine zuvor kopierte Quelldatei einzufügen.

Dies kann enorm viel Zeit in Anspruch nehmen, da die Anzahl an Dateien auf jedem Rechner permanent zunimmt – insbesondere seitdem Festplatten immer größer werden. Leider ist dabei ein koordiniertes Überschreiben älterer Dateien nicht immer einfach zu bewerkstelligen. Am Ende liegen Dokumente, Bilder, Musikstücke und Videos mit gleichem oder ähnlichem Inhalt überall verteilt auf der Festpatte herum während kein Mensch mehr weiß, wo die richtige Datei liegt, oder die größte oder auch die neuste.

Der 1-abc.net File Replacer hilft Ihnen dabei, all Ihre Festplatten, Ihren USB-Stick, Ihre Kamerakarte oder Ihr Netzwerk aktuell zu halten. Sie geben lediglich den Pfad oder mehrere Pfade an, in denen der Computer nach möglichen Ersetzungen suchen soll, fügen eine oder mehrere Quelldateien hinzu und bestimmen selbst, wann eine solch automatisierte Ersetzung stattfinden soll. Mögliche Kriterien dafür können neben gleichen Dateinamen auch das gleiche Erstellungsdatum, ein früherer Dateizugriff, eine geringere Dateigröße als bei der Quelldatei u.v.m. sein.

In einer Verlaufdatei wird automatisch protokolliert wo Ersetzungen dieser Art stattgefunden haben. Und wenn Sie denken, dass Sie den gleichen Ersetzungsvorgang häufiger ausführen möchten, können Sie Ersetzungsprojekte speichern oder laden, die aktuellen Einstellungen als Standard festsetzen oder das Programm automatisch von Zeit zu Zeit starten lassen.

Das Dateisystem durch Dateiersetzungen zu aktualisieren kann sehr kompliziert sein. Mit dem 1-abc.net File Replacer ist dies nur noch ein Klick – und Sie haben mehr Zeit für die wirklich wichtigen Dinge im Leben!

Funktionsübersicht:

  • Einfach bedienbare Programmoberfläche
  • Das Programm kann auch auf SD-Karten, USB-Sticks, externe Festplatten usw. zugreifen
  • Geben Sie so viele Ordner an, wie Sie wünschen, wo Dateien ausgetauscht werden sollen
  • Fügen Sie so viele Quelldateien hinzu, wie Sie möchten, die zur Ersetzung genutzt werden sollen
  • Bestimmen Sie selbst, welche Dateien in Bezug auf Größe, Datum u.v.m. überschrieben werden sollen
  • Kontrollieren Sie hinterher, welche Änderungen vorgenommen wurden, indem Sie sich die Verlaufdatei anzeigen lassen
  • Drucken Sie die Ersetzungsberichte lokal oder über das Netzwerk aus
  • Speichern und Laden von Ersetzungsprojekten
  • Konfigurierbare Ausnahmenliste für Dateien, die unter keinen Umständen ersetzt werden sollen
  • Ersetzte Dateien können in einem Backup-Ordner gesichert werden
  • Der Backup-Ordner kann vom Benutzer frei gewählt werden
  • Der Pfad zur Ausnahmenliste und zur Verlaufsdatei kann vom Anwender bestimmt werden
  • Binärmodus um einzelne Ausdrücke innerhalb einer Datei direkt auszutauschen
  • Das Programm kann auch auf USB-Sticks, Kamerakarten oder andere beschreibbare Medien installiert werden
  • Sehr niedrige Systemvoraussetzungen

Für Windows® XP / Vista / 7 / 8
Chef-Entwickler & Dokumentation: Stefan Siegert
Copyright 2005-2014 1-abc.net


Bevor es losgeht ...

Bevor es losgeht …

Der Windows Explorer selbst bietet nicht eine solch komfortable Datei-Ersetzungsmöglichkeit an wie dieses Programm. Vielleicht war dies eine bewusste Entscheidung der Entwickler, um mögliche Gefahren und Risiken zu vermeiden, falls der Anwender nicht genug darüber nachdenkt, was für Schäden er auf seinem System anrichten könnte. Wir möchten Sie daher darum bitten, vor einem Ersetzungsvorgang genau zu prüfen, ob Sie die richtige Quelldatei ausgewählt und die richtigen Ordner für den Ersetzungsvorgang angegeben haben. Dateien, die als 'schreibgeschützt' markiert sind, werden von diesem Programm nicht ersetzt. Außerdem werden alle ersetzten Dateien vor ihrer Ersetzung in den Papierkorb verschoben und können von da aus wieder hergestellt werden, falls dies nötig werden sollte. Als zusätzliche Sicherheitsoption können Sie die Backup-Funktion im Optionen-Bildschirm aktivieren, die die Dateien vor dem Ersetzen in einen Backup-Ordner kopiert, der sich je nach Windows-Version unter "Eigene Dateien" oder "Dokumente" befindet. Über den 'Optionen'-Bildschirm haben Sie die Möglichkeit, diesen Backup-Ordner zu ändern.

Bei Ersetzungsvorgängen im Binärmodus werden die Dateien vor der Änderung automatisch in den Papierkorb verschoben.

Das 1-abc.net Team wünscht Ihnen viel Spaß mit diesem Produkt!


Mit dem Programm arbeiten

Mit dem 1-abc.net File Replacer zu arbeiten ist sehr einfach. Hier sehen Sie, wie der Hauptbildschirm aussieht:

Zunächst müssen Sie einen oder mehrere Ordner hinzufügen, in denen nach Dateien gesucht wird, die ersetzt werden sollen. Dies können lokale Verzeichnisse ebenso sein wie ganze Laufwerke, USB-Sticks, Kamerakarten usw. Unterordner werden automatisch erkannt und mit durchsucht. Benutzen Sie die Buttons 'Ordner hinzufügen' oder 'Ordner entfernen' um Ihre Ordnerliste anzupassen.

Als nächstes müssen Sie mindestens eine Quelldatei angeben. Diese Datei oder diese Dateien werden dann später genommen, um andere Dateien zu überschreiben, falls die weiter unten angegebenen Ersetzungskriterien erfüllt sind. Benutzen Sie bitte die Buttons 'Datei hinzufügen' oder 'Datei entfernen', um die Quelldateiliste anzupassen.

Nun können weitere Kriterien zur Ersetzung angegeben werden. Der Dateiname muss grundsätzlich gleich sein, weiterhin ist es sinnvoll, nur Dateien zu ersetzen, die zur gleichen Zeit erstellt wurden und deren letzter Zugriff schon länger her ist als bei der Quelldatei. Dennoch, es kann durchaus Sinn ergeben, nur kleinere oder versteckte Dateien zu ersetzen, konfigurieren Sie das Programm an dieser Stelle einfach nach Ihren persönlichen Bedürfnissen.

Wenn Sie auf den Button 'Binärmodus' klicken, sieht der Bildschirm folgendermaßen aus:

Der Binärmodus arbeitet ähnlich wie der normale Modus, wurde allerdings speziell entwickelt, um einzelen Wörter oder Zeichen in *.txt-Dateien, *.csv-Datenbanken, *.html-Code oder anderen Dateien zu ersetzen, die sonst auch im Texteditor bearbeitet werden können. Die Dateiliste funktioniert ebenso wie im Normalmodus, im oberen Bereich können Sie jetzt die zu ersetzenden Zeichen definieren. Falls Sie also z.B. alle Ausdrücke 'Copyright 2005-2013' durch 'Copyright 2005-2014' ersetzen möchten, definieren Sie einfach eine solche Regel. Diese Funktion ist sehr praktisch, bedenken Sie aber bitte unbedingt, dass Sie sich vorher genau überlegen sollten, was Sie vorhaben. Beispielsweise kann man durch das Ersetzen eines einzelnen Zeichens in einer Musik- oder Bilddatei sehr schnell die ganze Datei zerstören.

Über den Button 'Weitere Optionen' können Sie ein paar zusätzliche Einstellungen vornehmen.

Dazu gehört der Timer, mit dem Sie das Programm in regelmäßigen Abständen automatisch mit Windows starten lassen können, die Anzeigeoption, ob Sie volle oder gekürzte Pfade angezeigt bekommen möchten oder ob die Verlaufdatei nicht benutzt werden soll. Hier finden Sie auch die Einstellung, um die Standard-Animation Ihres Windows-Systems, die beim Kopieren von Dateien angezeigt wird, zu deaktivieren, was sinnvoll sein kann, falls viele Dateien ersetzt werden und Sie währenddessen mit einem anderen Programm arbeiten möchten. Eine zusätzliche Bestätigung, bevor eine Datei ersetzt wird sowie die - neben dem Windows Papierkorb - zusätzliche Kopierfunktion für ersetzte Dateien in einen Backup-Ordner, der sich je nach Windows-Version unter "Eigene Dateien" oder unter "Dokumente" befindet, kann hier konfiguriert werden. Durch das Anklicken des 'Durchsuchen'-Buttons können Sie auch einen anderen Pfad als Backup-Ordner auswählen.

Im linken Bereich des Optionsbildschirms besteht weiterhin die Möglichkeit, bestimmte Dateien der Ausnahmenliste hinzuzufügen. Dies kann sinnvoll sein, falls bestimmte Dateien oder Dateien aus bestimmten Ordnern nicht ersetzt werden sollen. Mit einem Klick auf den 'Bearbeiten'-Button wird diese Liste im normalen Texteditor geöffnet, so dass Sie dort ebenfalls eigene Ausnahmen hinzufügen oder entfernen können.

Am unteren Rand des Dialogs haben Sie die Möglichkeit, die Pfade zur Ausnahmenliste und zum Verlauf direkt selbt zu bestimmen. Diese Pfade werden beim ersten Programmstart automatisch angelegt, eventuell möchten Sie diese Daten aber lieber an einer anderen Stelle speichern. Klicken Sie dafür einfach beim jeweiligen Verzeichnis auf 'Durchsuchen'.

Wenn soweit alle Einstellungen vorgenommen wurden, klichen Sie bitte auf 'Datei-Ersetzung starten!'. Hinterher wird Ihnen eine kurze Zusammenfassung angezeigt. Der Ersetzungsprozess kann jederzeit mit einem Klick auf den 'Abbrechen'-Button beendet werden.


Menü

Datei

Projekt öffnen
Öffnet eine Projektdatei, die zuvor mit diesem Programm gespeichert wurde.

Projekt speichern unter ...
Wenn Sie die gleichen Einstellungen später noch einmal gebrauchen möchten, können Sie diese in einer Projektdatei speichern. Geben Sie dazu einen Pfad und einen Dateinamen an.

Aktuelles Projekt als Standard festlegen
Wenn Sie die gleichen Einstellungen beim nächsten Programmstart wieder benötigen, wählen Sie bitte diesen Punkt aus.

Sprache auswählen
Wenn Sie die Programmoberfläche lieber in einer anderen Sprache betrachten wollen, können Sie diese Einstellung hier vornehmen.

Beenden
Hier können Sie das Programm beenden. Änderungen an den Optionen werden dabei automatisch gespeichert.

Funktionen

Optionen
Zeigt Ihnen den Optionen-Bildschirm an, über den Sie weitere Einstellungen vornehmen können.

Verlaufdatei anzeigen
Wann immer das Programm eine Datei ersetzt hat wurde dies in der Verlaufdatei protokolliert, die hier angezeigt werden kann.

Verlaufdatei ausdrucken
Hierdurch kann ein Ausdruck der aktuellen Verlaufsdatei erstellt werden. Wählen Sie dazu einen Drucker aus und klicken Sie auf 'OK' um mit dem Druckvorgang zu beginnen.

Verlaufdatei löschen
Wenn die Verlaufdatei für Ihren Geschmack zu lang wurde oder Sie die alten Einträge nicht mehr angezeigt bekommen möchten, setzen Sie die Datei hiermit zurück.

Registrieren*

Kostenlosen Testschlüssel anfordern
Von dem ersten Moment an, wo Sie das Programm benutzen, können Sie es 10 Tage lang uneingeschränkt starten. Diese Testphase kann auf insgesamt 30 Tage verlängert werden, wenn Sie sich für einen kostenlosen Testschlüssel registrieren. In diesem Fall wird Ihnen der Testschlüssel per E-Mail zugestellt.

Kostenlosen Vollversionsschlüssel anfordern
Falls Sie eine Version benutzen, die sich per E-Mail zur Vollversion freischalten lässt, klicken Sie bitte hier. Sofern Sie online sind, kann Ihnen in diesem Fall der Vollversionsschlüssel per E-Mail zugestellt werden.

Vollversion jetzt kaufen!
Wählen Sie diesen Punkt, um die Vollversion dieses Produktes per Internet zu erwerben. Dabei werden Sie mit einem Online-Shop verbunden, der Ihnen verschiedenste Zahlungsmöglichkeiten zur Verfügung stellt. Nachdem die Bezahlung getätigt wurde, erhalten Sie einen Vollversionsschlüssel, mit dem Sie das Programm sofort zu uneingeschränkter Funktionalität freischalten können.

Zu ... Upgraden
Wenn diese Version das Angebot enthält, zu einem anderen Softwareprodukt zu einem günstigen Preis upgraden zu können, lässt sich dieser Prozess von hier aus starten. Dabei werden Sie mit einem Online-Shop verbunden, der Ihnen verschiedenste Zahlungsmöglichkeiten zur Verfügung stellt. Nachdem die Bezahlung getätigt wurde, erhalten Sie einen Vollversionsschlüssel zu dem Upgrade-Produkt.

Schlüssel eingeben
Wenn Sie einen Test- oder Vollversionsschlüssel erhalten haben, können Sie diesen hier ganz einfach eingeben. Starten Sie nach der Eingabe das Programm bitte einmal neu.

*) Beachten Sie bitte, dass sich diese Menüpunkte unterscheiden können, je nachdem, ob Sie die Sharewareversion, eine normale Vollversion oder eine Vollversion nach E-Mail-Registrierung benutzen.

Hilfe

Hilfedatei anzeigen
Zeigt Ihnen diese Hilfedatei an. Entweder haben Sie diesen Punkt bereits ausprobiert, oder Sie haben die Taste „F1” gedrückt, was der andere Weg wäre, um an die Hilfedatei zu kommen.

Internetseite von 1-abc.net besuchen
Bringt Sie zur Internetseite von 1-abc.net . Dort können Sie weiterführende Informationen zu diesem Produkt erhalten und natürlich auch andere interessante Software herunterladen oder kaufen. Für diese Funktion sollte Ihre Internetverbindung hergestellt sein.

Über das Programm
Hier finden Sie Copyright-Informationen zu diesem Produkt.


Über 1-abc.net …

1-abc.net ist ein junges Unternehmen, das 2005 gegründet wurde und aus ambitionierten und sehr erfahrenen Programmierern, Marketingexperten, Distributoren, Grafikern, Übersetzern und Produktmanagern besteht. Der Hauptsitz ist in Deutschland, das Netzwerk aus Mitarbeitern und Freiberuflern erstreckt sich weltweit über sieben Länder.

Die von 1-abc.net abgedeckten Geschäftsfelder umfassen Softwareentwicklung, Softwarevertrieb, IT Consulting und IT Projektmanagement. Seit der Unternehmensgründung sind bereits über 30 Sharewareprodukte erschienen, die von zufriedenen Kunden aus über 50 Ländern der Welt genutzt werden. Neben speziellen Versionen für Zeitschriften-CDs/DVDs und für Internetseiten in ca. 20 Ländern werden 1-abc.net Programme auch von anderen Herstellern unter eigenem Namen als Boxprodukt in Lizenz vertrieben.

Und das bekommen die Anwender geboten:

  • Kleine Installationsdateien, die auch ohne Probleme mit langsamen Internetverbindungen heruntergeladen werden können.
  • Einfache Installation, ein Uninstaller ist immer enthalten.
  • Keine Adware, Spyware, Popup-Werbung oder was sonst heutzutage Software unnötig verlangsamt und vergrößert.
  • Sehr einfach bedienbare Benutzeroberflächen
  • Software, die den Bedürfnissen der Kunden absolut gerecht wird – nicht mehr, aber auch nicht weniger.
  • Einfache Möglichkeit, die Testphase mit einem kostenlosen Registrierungsschlüssel zu verlängern.
Außerdem bietet 1-abc.net mehr als zehn Apps für Android™ Smartphones und Tablet PCs sowie Windows Store Apps an. Auf der Internetseite http://mobile.1-abc.net/de können Sie mehr darüber erfahren.

Support

1-abc.net
Grünenstr. 120
28199 Bremen

Deutschland

Zurzeit ist leider kein Telefon-Support möglich. Besuchen Sie bitte folgende Internetseite um eine Auflistung der häufigsten Fragen angezeigt zu bekommen oder um uns eine E-Mail zu senden:

http://de.1-abc.net/support.htm